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Introduction 
The purpose of this document is to give you a complete overview of the functions and 
features of the HP Ergosoft Pro RIP Color Edition.  
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HP Ergosoft RIP Color Edition Installation 
Installation Procedure 

To begin with the Installation, navigate to the folder you downloaded the HP Ergosoft RIP 
Color Edition to. Many browsers will default to downloading files to «Downloads» under 
Windows, but it might be somewhere else if you chose a custom save location.  

 

  

After a moment, the welcome screen will appear. Simply click next to proceed with the 
installation. 

Read and confirm the Software License Agreement using the I Agree button. If you do not wish 
to accept the software license agreement, click Cancel to quit the installation. 

 

  

Double-click on the setup file and wait 
for the installer to prepare the 
installation.  

On modern Windows systems, you 
might need to confirm a firewall 
message to allow access for the 
installer. 

  

 

Select the user interface language for the 
software. The installation and user interface of 
the RIP will then be displayed in this language.  

 

This setting can easily be changed after the 
installation should you wish to use the software 
in a different language later on. 
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Select the installation directory for the main HP 
Ergosoft RIP Color Edition program. This is 
where the software itself will be installed to.  

By default the suggested path will be in the 
Windows program directory but you may install 
the program to a custom location. To do so, click 
Browse and select the folder you wish to install 
the software to. 

 

 

 

Select the Start Menu Folder, this is 
the folder the RIP will appear in when 
you access the Windows Start button.  

When you are satisfied with your 
choice, click Install and wait for the 
installer to finish copying files. 

 

 

 

 

 

 

Towards the end of the installation, a prompt will 
appear, asking you to select a User Data folder. 
This is the folder where your user specific data 
such as software configuration, profiles, etc. will 
be stored.  

Generally we recommend using the default path 
to ensure Windows gives the program full 
access to the folder, but you may of course 
select a custom path by clicking the Change 
Folder... button.  

When you are satisfied, confirm with Ok to 
continue. 
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After a moment, another prompt will 
appear asking to plug in the dongle.  

 

 

Make sure the silver USB Dongle you 
received with your HP Ergosoft RIP Color 
Edition is currently plugged into the 
system, then confirm with Ok. 

 

 

 

 

Wait for the file copy process to finish, then 
press Next. Another dialog will appear with a 
checkbox that lets you set if a shortcut to the HP 
Ergosoft RIP Color Edition should be created. 

 

Click Finish to complete the installation. 

 

 

 

Congratulations! You have successfully installed the HP Ergosoft RIP Color Edition! 
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Initial Configuration 

When first starting the HP Ergosoft RIP Color Edition, you will be prompted to do some initial 
configurations. 

Start the software by double-clicking the Desktop Shortcut. After a moment, the Print 
Environment dialog will appear with a prompt stating that «No Print Environment has been 
defined».  

 

You have 3 options to add a new Print 
Environment: 

Add: Lets you select your printer model 
and create a new, empty Print 
Environment without density linearisation 
or profile. 

Import: Lets you import an existing Print 
Environment from a .PrEnv or PrEnvPck 
file. 

Download: Connects to the HP Ergosoft 
RIP Servers and allows you to download 
from a selection of  pre-configured Print 
Environments containing Density 
Linearization and Profile. 

 

 
Configuring a Print Environment with Add 

If you selected Add, the software will automatically start the PrintClient configuration for you. 
In the Select PrintClient Window, click the Icon to add a new PrintClient and configure 
your port. The HP Ergosoft RIP Color Edition will then display a list of the available printers. 
Select your model. 

 

The next dialog sets up the PrintClient, a 
waiting queue to manage print jobs.  

By default, the folder for temporary spool 
files will be created in the User Data folder, 
but you may of course customize the 
folder, though it is recommended to make 
sure there is enough harddisk space 
available at the selected location for the 
spool files, as they may reach several GB 
for large print jobs. 

Since at this point we don’t have any 
predefined port to select for the 
PrintClient, click Add Port. 
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In Add Port, select the port type HP TCP/IP 
and confirm with Ok to continue with the port 
configuration. 

 

There are now two options to add the port. You may either:  

 

Click on Search Printer to auto-detect the 
printer in the network, then select the 
appropriate one from the list.  

 

Or  

 

Enter the IP address into the respective 
field at the bottom. 

 

Connect and Send timeout can be left at 
their default values in most cases.  

 

 

When you are done, click Ok to confirm and get back to the PrintClient configuration window. 
In Port, you’ll find the printer port we just created already preselected.  

 

Confirm with Ok and specify a name for your PrintClient, confirm the selection, and finally enter 
a name for your newly created Print Environment to complete the initial configuration. 

 

Configuring Print Environment with Import & Download 

After you have imported or downloaded your initial Print Environment through the respective 
button, we will need to configure the printer port so we can send data to the printer.  

 

To do this, select the Print Environment 
you added in the Print Environments 
dialog and click the Settings button. 
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Navigate to Output Device. As we have not 
yet defined a port, the dropdown list of 
PrintClients will be empty. Click on the  Icon 
to add a PrintClient and define the printer port. 

 

 

In Add Port, select the port type HP 
TCP/IP and confirm with Ok to continue 
with the port configuration. 

 

 

There are now two options to add the port. You may either:  

 

  

Click on Search Printer to auto-detect the 
printer in the network, then select the 
appropriate one from the list.  

Or  

Enter the IP address into the respective field 
at the bottom. 

Connect and Send timeout can be left at their 
default values in most cases. 

When you are done, click Ok to continue. 
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The next dialog sets up the PrintClient, a 
waiting queue to manage print jobs.  

By default, the folder for temporary spool 
files will be created in the User Data folder, 
but you may of course customize the 
folder, though it is recommended to make 
sure there is enough harddisk space 
available at the selected location for the 
spool files, as they may reach several GB 
for large print jobs. 

When you are happy with the 
configuration, confirm with Ok. Then 
confirm the Print Environment settings 
dialog with Ok.   

 

This completes the Print Environment and port setup and brings you to the main RIP interface, 
called the JobComposer. 

At first launch, the JobComposer will show the Awareness Screen, highlighting the HP Color 
Tools features. When you are ready, close the dialog by confirming with Ok. 

 

  



Reference Manual – HP Ergosoft Pro RIP Color Edition  9 

First Print 

To print your first job, first open the PrintClient we configured earlier by clicking on the 

PrintClient Icon in the toolbar. Note that clicking the PrintClient icon  will always open the 
PrintClient set in the currently selected Print Environment. 

 

 

When the PrintClient opens, set it to Online by 
clicking on the first of the 3 dots at the top right 
so it turns green.  

When set to Online, the PrintClient will 
automatically send all data to the printer as 
soon as it is ready.  

When set to Offline, it will not send any data 
to the printer, but instead prepare the raster 
data and place it in the waiting queue until the 
PrintClient is set to Online. 

 

Go back to the JobComposer and import 
an image file by clicking the Import  button 

. 

Then navigate to your image file, select it 
and click Open. 

 
 

Once the image is imported, you can make further adjustments to it in the properties bar to 
the right like scaling, rotating etc.  

 

 

When you are satisfied, make sure the printer 
is ready, then click the Print Icon . Double 
check the copies and settings in the Print 
Dialog, then confirm with Ok to send your job 
to the printer. 

 

You can now follow the progress of your Job 
in the PrintClient window as well as see Job 
Details, manage your Job queue, change 
priorities, abort jobs, etc. 
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Initial Setup 
For a detailed description of a first setup of the HP Ergosoft Pro RIP Color Edition, please 
refer to the website www.Ergosoft.net/hp. 

 
Output Device Settings 
The Output Device settings allow you to set up a printer or printer/cutter configuration which 
determines how the data is sent to a specific printer or printer/cutter. Once created, this 
configuration file can be selected whenever you create a new print environment for this 
printer or printer/cutter.  

Creating the Printer Port 

In this dialog you can specify the required information, such as the printer port to be used 
and the spool folder, create a new printer configuration by clicking the Add Port button. 
Select the required port in the Add Port dialog. In the displayed Edit Printer Port Settings 
dialog, you create the printer configuration. Set your desired connection method and Spool 
Folder. When closing the dialog with OK, you are prompted to enter a name for the new Print 
Client. 

Once you have created an Output Device, you can edit, delete or rename it using the 
respective buttons. 

Specify Printer 

The displayed dialog Edit Printer Settings allows you to specify the above-mentioned 
settings.  

Specify Folder for Spool Files 

In order to specify the spool folder, click on Browse in the Folder for Spool Files section. 
Select or create a spool folder in the “Browse for folder” dialog. 
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Print Settings  
The Print Settings dialog for the new print environment should now open.  

Please read on for a brief description of the available and required settings. 

Quality Tab 

1) First, specify the Resolution to be used. 

 

2) HP Ergosoft Pro RIP Color Edition “Digital Printing Applications” is selected in the Print 
Environment settings as dithering for digital printing applications and offers greater speed 
and smoother, more accurate dot placement. This dithering method is also internally referred 
to as Stochastic 3sf. 

Thus, when selecting the Dithering Method, Digital Printing Application is usually the best 
choice because it is a good compromise between speed and quality. For more options to 
choose from, you can check “Show all”. This will show all Dithering methods which are 
available in the HP Ergosoft Pro RIP Color Edition. 
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Printing Ink Assignment Tab 

The Printing Ink Assignment tab gives you control of the ink’s positions in the printer, as 
well as light ink blending settings. If you are not sure which slot an ink is located in, simply 
select Print Ink Assignment Chart from menu Tools > Linearization & Profile Tools which will 
automatically print out each color along with a number which indicates the corresponding 
slot. 

 
Device Options Tab 

In this tab you can choose the device specific options you want to use. Among these settings 
are – depending on your printer – print direction, number of passes, dot size, dry time, etc. 

If you use a predefined print environment, please keep in mind that these settings have 
influence on the quality of the final printout. 

 
Closing the Print Settings Dialog 

After having completed the settings, close the dialog Print Settings by clicking the OK 
button.  

 

For best results, you should also complete the following steps: 

 

1. Create a Density Linearization 

2. Find and set the maximum amount of applied ink 

3. Create a printer profile. 

 

For more information about the print environment configuration please refer to the according 
application note. 
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Printing with HP Ergosoft Pro RIP Color Edition 
Basics of Printing 

 

Basically, the data flow when having launched the Print command is the same for all 
possibilities: The JobComposer (main program you are working with to create your jobs) 
forwards the print command including all necessary data and information to the 
JobQueueServer which shows its processes in the JobCenter parts of which are displayed 
in the JobComposer windows Waiting, Done, Preview, Details, and Journal. The 
JobQueueServer controls data ripping in the RIP Server and forwards the ripped data either 
directly to the printer or into a Print Client that controls the printer. 
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General Print Workflow 

 

When having launched the print command, the JobQueueServer sends the job data to the 
RIP Server for ripping. The RIP Server returns the ripped data to the JobQueueServer that 
sends the ripped data to the Print Client that sends the ripped data to the printer.  
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RIP Modules 
JobComposer 

The JobComposer is the heart of the HP Ergosoft Pro RIP Color Edition. It is used to create, 
layout and print all your jobs. The Application Look as well as the Accent Color can be 
selected under menu View. 

 
JobCenter 

The JobCenter allows specifying global rules for deleting and archiving done jobs; it 
manages and gives information about printed jobs. 

 
RIP Server 

The RIP Server is used to track the rasterization and ripping process as well as to configure 
the PostScript interpreter. 

 
Album 

The Album allows managing the previews of the images that are displayed in the job.  

 
Preview Server 

The Preview Server updates previews and creates snapshots. Snapshots are automatically 
created and used for the display in the job and image editing functions instead of the large, 
high-resolution original image file. 

 
Print and  Cut Clients 

The Print Client controls the data transfer of ripped files from a certain folder to a certain 
printer; the Cut Client controls the data transfer to a cutter. Further the print client gives 
information about the ripping progress, the files which are waiting for print, the printed files as 
well as the errors occurred. It allows you to see the costs for your printing as well as the ink 
consumption.  

The details, the journal and the preview are displayed on the right side of the print client and 
allow you some additional information. 

Note: During the printing process you still have the possibility to change the number of 
copies. 

 
Setting up and Using a Print or Cut Client 

/  icon in the toolbar or Tools > Print/Cut Clients > Setup or Printer and Port tab 
respectively Cutter Device tab in print environment or cut environment settings. 

 
  

http://dict.leo.org/ende?lp=ende&p=Ci4HO3kMAA&search=respectively&trestr=0x8004
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User Interface  
Application Appearance and Workspaces 
Besides the user interface and software illustration, the application appearance as well as 
the accent color can be customized and selected under the View menu. 

 
Workspaces 
The HP Ergosoft Pro RIP Color Edition offers a variable workspace; the standard, edit or 
custom workspace. Depending on what you are doing you can adept the workspace. The 
edit workspace enlarges for example the preview window given that you work on it for 
several manipulations. You can create your own workspace. 

 
Creating a New Workspace 

View > Workspaces > Save as > New 

 
Using a Predefined Workspace 

View > Workspaces > Standard, Edit or Print and Cut 

 
Changing the Application Look  

View > Application Look  

 
Changing the Accent Color 

View > Accent Color 

 
Integrated Job Queue 
Integrated in the JobComposer window, the integrated job queue allows you to check the 
printing progress, the done jobs as well as their details and preview while you are editing a 
new job. This permits you to optimize your working time and organization.  

 
Properties and Selection Windows 
You have the possibility to display, to hide, to separate and to resize all different windows. It 
is advisable to keep the Properties window always displayed since it offers the access to 
many functions. The Selection window offers also many options and it is recommended to 
keep it open while editing your job. 
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Design Program Window 
The different bars allow a quick access or information to all basic functions.  

 
Toolbar 

This command shows or hides the toolbars - View > Tools > Different Toolbars 

Toolbar Standard holds icons for job managing functions as well as for fast access to some 
often needed modules. 

 

Toolbar Print Environment holds functions for fast print environment and configuration 
access as well as the filter icon which helps to sort existing print environments.  

 

The toolbar ImagePreset holds the icon for fast image preset and configuration access 

 

Toolbar Cut Environment holds functions for fast cut environment and cut configuration 
access. 

 

Toolbar Position holds functions for fast image scaling and positioning. 

 

Toolbar View holds icons for job zooming functions, also in View. 

 

Toolbar Image holds functions for image editing and handling. 

 

Toolbar Tools holds icons for color management functions. 

 

Note: You can move and replace all toolbars by holding the mouse on it until  appears. 
Slide the toolbar to the place you want and release the mouse button. 
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Status Bar 

This command shows or hides the status bar. The status bar is located at the lower border of 
the JobComposer window. It is used to display information about the current program 
status, the selected image, messages, and short help texts to the selected menu item. 

 
Activating the Status Bar 

View > Status bar 

 

 
Rulers 

This command shows or hides the rulers in the job window. When necessary, both rulers can 
be shown at the upper and left border of the job window. These can help when designing the 
job. 

 
Activate the rulers 

View > Rulers 

 

 
 
Job Zooming Functions 
The job zooming functions allow zooming in, out, to width or to height. 

 
Zoom In 

Magnify the output on the screen - Zoom In - Ctrl++ 

 
Zoom Out 

Reduce the output on the screen - Zoom Out – Ctrl+- 

 
Zoom to width 

Zoom the view to the width of the job - Zoom to Width - Ctrl+0 

 
Zoom to height 

Zoom the view to the height of the job - Zoom to Height - Ctrl+1 
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Guide Lines 
The guidelines in the HP Ergosoft Pro RIP Color Edition job window are handled in the same 
way as in the current graphic programs by Adobe Inc. To insert guidelines, you need to 
activate the rulers. Drag down from the upper ruler to get a horizontal guideline; for a vertical 
guideline drag from the right guideline. 

 
Activate guide lines 

Edit > Guide Lines 
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Print Environment 
Using and Creating Print Environments 
The Print Environment is the cornerstone of HP Ergosoft Pro RIP Color Edition. It allows 
you to define all the necessary information and settings to print on a particular 
printer/media/ink combination. It contains the printer driver, the dithering method, the 
linearization of the printer, the output profile, the total ink limit, the port used, and other 
device settings. Every printer needs different print environments related to the ink and the 
media to get the best printing result. You must create a specific profile for each medium. 

Print Environments are saved as attributes of the Job. If switching between Jobs, the Job 
Composer will automatically load the Print Environment which was last used for the selected 
Job. Using this mode can help to reduce difficulties if working with several open jobs at the 
same time.  

 
Access to the Print Environment Dialog 

 icon on the toolbar or Tools > Print Environments… 

 
Using a Predefined Print Environment 

HP Ergosoft Pro RIP Color Edition offer a number of predefined print environments available 
on the web. To download these print environments, click on Download to connect to the 
Print Environments Server. Select one which fits best to your actual combination of printer, 
ink, and media. 

 
Importing a Print Environment 

If you want to import a print environment from another place, please click on Import and 
navigate to the target folder. 

 
Creating a New Print Environment 

Press Add to create a new print environment and click on New. The list shown here contains 
all drivers supported by the HP Ergosoft Pro RIP Color Edition. 

 
Removing a Print Environment 

Hit the Remove button. Be careful! A removed print environment is deleted if you did not 
save it somewhere else before. 

 
Saving a Print Environment 

Click on Export and save it in a new folder. 
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Modifying a Print Environment 

It is advisable to copy an existing print environment for modifying the settings. Press Copy 
and change the name of the copied print environment. If you want to keep the same settings 
and only change the name of a print environment, click on Rename. 

 
Manage Write protection 

If you only want to read a print environment, tick the Manage write protection case and 
select all print environments you want to protect. A lock next to the name indicates the 
protection. This option allows you to see all the settings but it is impossible to change them. 
This gives you a certain security protecting good profiles. 

 
Tree Structure 

You can either show all of the already existing print environments in a list or group them by 
names. To get this grouped order, check the Tree Structure checkbox. 

 
 
Print Environment Settings 
All print environment settings can be set and modified as long as no printer profile is 
activated. After the inclusion of the profile nothing should be changed anymore. The following 
tabs contain the print environment settings: 

 
The General Tab 

Here you can change the name, give a general description, specify media (for cost 
calculation) and indicate the printer model. The Name as well as the Description of a Print 
Environment can now be generated by using “Auto” Button in the General Tab of the Print 
Environment. The generated Name and Description can be edited. The Generator will create 
the Print Environment Name based on the used Base Driver, the No. of set Printing Inks in 
the Printing Ink Assignment, the used Resolution and the used Major Version. It also adds 
the current date and the logged user. The Description will contain the following information: 
Dither/Resolution/PrintMethod/DotSizes/Media/DriverInfo/Heater Info/Colors/Version/Time 
created/User 

 
The Quality Tab 

Allows you to specify the resolution and the dithering method, to adjust light ink settings and 
dot sizes, to limit the ink amount and to use a density linearization and printer profile. 

 
The Output Device Tab 

Allows you to set up a printer configuration which determines how the data is sent to a 
specific printer. Once created, this configuration can be selected whenever you create a new 
print environment for this printer. The Print Client can also be activated and set here. 

 
 

 

http://dict.leo.org/ende?lp=ende&p=5tY9AA&search=either
http://dict.leo.org/ende?lp=ende&p=5tY9AA&search=or
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Printer Pools Option 

Each Print Environment in the new HP Ergosoft Pro RIP Color Edition is linked to one 
specific Printer ID. A Printer ID is comprised of one specific printer type, a port connection 
and a spool folder. Once a job is in the process of ripping and printing, this connection 
cannot be changed. In production situations where many identical printers may likely be in 
use, having to create and manage separate Print Environments for each printer can become 
cumbersome. Preparing a Printer Pool allows creating sets of identical or suitable printers 
and to link them to separate print environments rather than one specific Printer ID. Whenever 
this Print Environment is used to create a job, the job can be printed on any of the member 
printers in the pool. Should multiple copies of the printed job be required, it becomes possible 
to divide the number of copies onto several of the printers in the pool simultaneously. Only 
printers of identical printer types may become members of a printer pool. Once defined and 
set up, a Printer Pool may be used in several Print Environments. 

 
The Extras Tab 

Contains the legacy ink control strips, job mirroring, automatic size change consideration, 
target printer simulation and the Named Colors Profile. 

 
Printing Ink Assignment Tab 

Gives you a control of the ink’s positions in the printer. If you are not sure in which slot an ink 
is located in, go to Tools >Linearization & Profile Tools > Print Ink Assignment Chart, which 
will automatically print out each color in all dot sizes available with the number that indicates 
the corresponding slot from left to right. 

 
The Ink Control Tab 

Allows keeping a control over all inks in the printer. The production stripes can be set by 
side, width, horizontal distance, stripes count and coverage. Note that coverage is set for 
each ink, 4 inks each with 100% coverage means 400% ink on your media! The visual 
control stripes show more in detail the evolution of the ink during the printing process. You 
can select the side, the width and height with the corresponding distance, the shade count 
and the mode (one column, dot sizes in row or continuous) with all dot sizes or just the 
biggest one. 

 
Media Size Tab 

To set up a specific media size which should always be used for a specific print environment, 
check the option Use as default for this Print Environment and select or add the default 
media size you want to use for the printer. Some printers have this information in the printer 
driver and transmit it to the program. The media size is handled in the global options by 
default, located in the menu bar Tools > Options > Preferences > Job > Job Default Settings 
> Media Size. 
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Ink Cost Tab 

Shows you the consumption of ink per dot for each dot size. It is possible that for a specific 
printer you have to enter yourself the values given by the printer manufacturer. This 
information does not have any influence on the printing behavior, but they are necessary to 
calculate the printing cost. Further allows specifying the ink for cost calculation. 

 

Device Options Tab 

You can choose the device specific options you want to use. Among these settings – 
depending on your printer and your medium – are print direction, number of passes, dot size, 
dry time, etc. If you use a predefined print environment, please keep in mind that these 
settings have an influence on the quality of the final printout and changing them is not 
recommended. 
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Job 
Job Handling 
A job basically represents the media which is in your printer. Multiple jobs can be edited at 
the same time in multiple windows. The job size (usually=media size) including margins can 
be set for each job any time. 

 
Creating a New job 

Click the  icon in the toolbar, Ctrl+N, File > New. 

 
Specifying the Job Size 

Click the  icon in the Properties window or Tools > Options > Preferences > Job > Job 
Default Settings > Media Size – either basic settings or ask for every new job. 

 
Opening an Existing Job 

An existing job can be opened with all settings – File > Open. 

 
Opening a Recent Job  

To open a recent job – File > Recent Jobs. 

 
Multi Page Jobs 

To get several pages per job click right on an image and choose Page per Image. 

 
Saving a Job 

A job can either been saved under its current name or under a new name – File > Save or 
Save as…, Ctrl+S. 

 
Closing a Job 

To close a job, click either on the x on the right top corner of the job or File > Close. 

 
Closing All Jobs 

To close all jobs at once – Window > Close All Documents 

Note: You see the name of all opened jobs listed in the window menu. 
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Tabbed job view 
You can open several jobs at the same time. They will be tabbed and you can change from 
one to the other.  

 

 
Visualizing Multiple Jobs 

To visualize 2 jobs at the same time, click right on one tab and choose New 
Horizontal/Vertical Tab Group. 

 
 
Adding Image or Job Element to Job 
Importing Image 
This command adds images to a job. In HP Ergosoft Pro RIP Color Edition, any number of 
images can be added to a job. You can select a predefined Image Format while importing an 
image using an Image Format. 

 
Importing Images 

 icon on the toolbar, File > Import Image or Ctrl+I. 

 
Opening a Recent Image 

To open a recent image, click right or File > Recent Image 
Note: Recent images are imported using the same import format as before. 

 
Adding Job Element 
You can insert a gradient rectangle, a job length line, a separation line between images or a 
variable text on your job.  

 
Add a Job Element 

File > Add Job Element or right click > Add Job Element. 

 
Modify added parameters 

Image > Edit Parameters. 
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Editing Job 
The job window shows you the imported images that you can edit now. The HP Ergosoft Pro 
RIP Color Edition allows you to format your images in an easy and intuitive way. To arrange 
the image on your job window you have several options like positioning, rotating etc. 

 

Arrangement of the Images 
Nesting 

The new Nesting feature, fully integrated into the JobComposer and the HotFolder 
application, improves the automated arrangement of multiple images per job.  

It offers two different basic modes:  
 Easy Cutting (Guillotine Cut) 
 Minimum Waste (Space Optimized) 

Easy Cutting (Guillotine Cut) arranges the images in a way that a horizontal cut line is 
provided, ensuring a smooth finishing of the job. Minimum Waste (Space Optimized) nesting 
arranges the images in the most space saving way to minimize the waste of paper. Both of 
these modes can be selected either with Rotation or without Rotation. 

To create Nesting go to the menu Edit where you can choose following 5 options: 
 Easy Cutting Allow Rotation 
 Easy Cutting No Rotation 
 Keep Image Order 
 Minimum Waste Allow Rotation 
 Minimum Waste No Rotation 

 
Selecting Images 
To modify an image, it must be selected. You can either select one or several images. The 
blue squares in the image corners indicate which images are selected and which one is 
active (bigger blue square). 

 
Selecting One Image 

Mouse click on image, to move from one to the other tab key. 

 
Selecting Several Images 

Ctrl key while mouse click on selected images. 

 
Selecting Successive Images 

Drag rectangle with the mouse on selected images or Shift key and mouse click on first and 
last image. 
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Selecting All Images on the Job 

Ctrl+A or Edit > Select All. 

 
Positioning Images 
It can be important to position your image on a certain place on the job; e.g. to save media, 
to print the image on an exact distance to another image, or for any other reason. 

 
Numerical Input 

 icon on the Properties window and the toolbar, V key. 

 
Simple Positioning 

Drag image with the mouse. 

 
Positioning Adjoining another Image 

Drag image with the mouse, hold down Shift key while releasing left mouse button. 

 
Activating Overlay Mode 

Edit > Overlay Mode, you can overlay all images.  

 
Split overlaid images 

Image > Split Overlay or right click > Split Overlay. 

 
Alignment Functions 

Image > Center 

 
Grouping Images 

Image > Group or right click > Group. 

 
Moving an Image to another Job 

Drag with the mouse. Keeps all image formats (get paneled if job is smaller). 

 
Cancel Moving 

Press Esc while moving, Ctrl+Z, Edit > Undo. 
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Rotating Images 
Rotating images is often useful to save media, diversify the print direction on a structured 
media etc. Attention: Printing rotated images consumes more calculation time and therefore 
can reduce the output speed!! 

 
Rotating Images 

By 90°, 180° or 270° -  icon on the Properties window, R key or Image > Rotate. 

 
Rotating Image Parts 

By 90° -  icon on the toolbar, Alt+Ctrl+R, or Image > Rotate Part. 

 
Mirroring Images 
Allows you to mirror complete images or image parts horizontally. 

 
Mirroring Images 

 icon on the Properties window or  icon on the toolbar, Ctrl+M or Image > Mirror. 

 
Duplicating Images 
This option creates copies of the selected image. You can either create one copy of the 
image or generate a grid of duplicated images. 

 
Duplicating Images 

 icon on the Properties window and the toolbar, Ctrl+D, Image > Duplicate, Ctrl+hold left 
mouse button, duplicate and position next to another image using Shift+Ctrl. 
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Image Layout 
Scaling Images 
Extends or shrinks the selected image to any size. 

 
Access to the Scaling Dialog 

 icon on the Properties window and the toolbar, S-key. 

 
Numerical Scaling 

Can be done by changing the size in selected unit or by absolute or relative %. 

 
Manual Scaling 

Proportional scaling by dragging one corner of the image  

 
Cropping Image 
This command allows that only a part of the current image is used and the rest is discarded. 

 
Access to the Cropping Dialog 

 icon on the Properties window and the toolbar, C key. 

 
Numerical Cropping 

In the Properties window in selected unit on left, right, top or bottom side. 

 
Manual Cropping 

In the Preview window. 

 
Tiling Images 
When importing an image that is wider than the job, the image gets automatically tiled. 
Manual tiling allows you to define the size of the different tiles. You can separate the image 
in horizontal and vertical cut tiles, as well as rotate one of two or print every tile on a separate 
page what allows you to easily reprint one specific tile of the job. 

 
Manual Tiling 

 icon on the Properties window 
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Disconnect Parts 

To treat each tile individually you need to disconnect parts – Image > Disconnect parts 

 
More Image Layout Functions  
In addition to the basic image layout function some special functions are available with the 
HP Ergosoft Pro RIP Color Edition. 

 
Print Marks 

To have some information on your printout you can set print marks –  icon in Properties 
window, right click > Print Marks or Image > Print Marks. 

Note: You can edit print mark presets, use a predefined one or create a new one. 

 
Undo/Redo 

Allows you to cancel or to restore a manipulation. 

 
Center 

Centers the image precisely in the job or media (width). 

 
Group 

Allows you to group several images. All manipulations are done for the whole group. 

 
Export 

Allows you to export an image including color management to any folder. 

 
Edit 

Available when a program for image editing is specified in the options. 

 
View  

Available when a program for image viewing is specified in the options. 
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Printing a Job 
This command controls the job output.  

Using the Print Client is mandatory and helps to handle and manage printing jobs as well as 
to avoid errors during production through an easy, intuitive interface. 

 
 

Image Preset 
Use Image Preset 
The Image Preset function allows you to save the main image settings. You can generate 
different pre-settings and choose the one you desire for each job no matter how many 
images are in there. This function helps you to save time due to the fact that you do not have 
to repeat basic settings for each image. For detailed information about handling image 
presets please refer to the concerning application note. 

 
Image Preset for Import 

Select the desired Image Preset in the dropdown menu of the toolbar. The Image Preset 
will automatically be applied to all imported images. 

 
Use or Change Image Preset on Already Imported Images 

To apply or change an Image Preset on an already imported image Right Click on the 
desired image > ImagePreset > select desired image preset. 

 
Create Image Preset 
For detailed information about handling image presets please refer to the application notes. 

 
Create new Image Preset 

Click the New button in the Image Preset toolbar to create a new Image Preset based on 
the selected one. 
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Image Preset Settings 
The main settings of the image preset are identical to the global job settings. Starting from 
V15 it’s possible to add multiple AddOns for the same image. 

 
Edit 

 Image format - scale, fit and alignment, rotate and mirror. 
 Print marks - crop marks, register marks, image label. 
 Image AddOns - company logo, seam extension, canvas mounting extension, dashed cut 

line, label (new one) And this AddOns can be installed: Caption, Eyelets, Gradient Frame, 
Solid Frame, Seam Margin etc. Note that some Add-Ons need to be added from the 
“Install” menu before they can be used. 

 Image margin – predefined margin or personal margins, rotate margins with image. 
 
 
Color Management 

 Raster images – select color profiles to be used for images as default input profile – RGB 
images, CMYK images, Lab images with respective rendering intent, input profile for Grey 
Data. 

 PostScript/EPS - use named colors profile for spot color replacement, input profile for 
CMYK data -  chose profile and rendering intent, input profiles for RGB data – choose 
profile and rendering intent. 

 PDF - use named colors profile for spot color replacement, input profile for CMYK data -  
chose profile and rendering intent, input profiles for RGB data – choose profile and 
rendering intent, input profile for Grey data – choose profile and rendering intent, input 
profile for Lab data - choose profile and rendering intent. 

 
PostScript/PDF 

Parameters - automatic raster resolution reduction, minimum resolution, raster resolution 
reduced by factor. Starting from Version 15 Ergosoft uses the well-known PDF Engine 
Aurelon. 

 
List Manager 
The image preset list manager allows you to edit, delete or rename the different parameters 
of the image preset or to choose a predefined one. Modifying an existing image preset is 
only possible in the list manager. 
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Composite Presets 
Default Presets 
The default presets allow an access to the application defaults. 

You can either change settings in an existing preset (  ), delete it (  ), rename it (  ) or 
create a new one (  ). 

Note: For the image presets you have the same functions. For further information, see in 
chapter Image Presets. 

 
 
Image Color Control 

Color Management 
Color management describes a controlled conversion between the colors of various color 
devices such as scanners, digital cameras, monitors, printers, and corresponding media. 

The primary goal of color management is to obtain a good match across color devices. For 
instance, imagine an image which should look the same on all media printed with any printer. 
Color management helps to achieve the same appearance on all media and printers, 
provided the device is capable of delivering the needed color intensities. Therefore, some 
rules must be respected. 

The color management is split into color management for 

 Raster Images (TIFF, BMP, PNG, JPEG, PSD) 
 PostScript (PS) and EPS 
 PDF and AI 

 
Components of Color Management 

Input Profile 

Controls the conversion from the image color space to Lab. The color profile characterizes 
the source of the image data. Select the color profile in the list that corresponds to the source 
of the image data. When a monitor profile has been selected, the effects of the selected color 
profile can be seen in the preview window.  icon in the Properties window or Tools > 
Options > Preferences > Color Management.  

Rendering Intent 

The rendering intent specifies how out-of-gamut colors of the device-independent Lab color 
space are to be converted into the printer gamut. This conversion is necessary because the 
Lab color space holds much more colors than the printer gamut. Select the Rendering intent 
to be used for printing the selected image.  icon in the Properties window or Tools > 
Options > Preferences > Color Management. 
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Color Replacement 
The color replacement function allows customizing the ink mixture of certain colors in the 
images according to your needs and letting the color management control the ink mixtures of 
the rest of the image. 

 
Access to Color Replacement 

 icon in the Properties window. 

Note: To see the colors of your selected image, click on “Show Colors”. 

 
Color Replacement Presets 
Color replacement presets have lists of RGB/CMYK/Lab/Gray values that are automatically 
replaced by the specified Lab or device color values. Color replacement presets can be 
activated globally or selected just for the current image. 

 
Access to Color Replacement Presets 

Tools >Options> Preferences > Color Replacement. 

 icon in the Properties window. 

 
Tune 

The tune function allows setting the saturation, brightness and contrast, the color balance 
and the gradation. In the Preview window you can display either only the preview, the original 
image and the preview, the printer preview, the pixel color information as well as all colors 
out of the printer gamut. 

 
Access to Tune 

 icon in the Properties window. 

 
Pure Colors 

While selecting one of the colors in the pure colors dialog, this color will not be modified by 
the color management if it contains only this color in the original image. This function allows 
avoiding visible dots of another color. 

 
Access to Pure Colors 

 icon in the Properties window or Tools > Options > Color Management > Raster Images > 
Pure Colors. 

 
  



Reference Manual – HP Ergosoft Pro RIP Color Edition  35 

Color Tools 
 
Generate Colorbooks 
This command creates a job containing Lab or RGB colorbook. 

 
Generate a New Color Book 

Tools > Color & Special Features > Generate Colorbooks. 

 
Colorbook Options 

In the Options you can define the fields size, the title, the label and a comment as well as 
the resolution of the printing. 

 
Generation of Many Different Color Tones 

Often, desired colors are not printed in the colorbook because they are between the colors 
representing the selected hue distance and number of lines. The smaller the distance and 
the more lines per page are printed in the colorbook the more different color tones are 
printed. 

 
Swatch Book 

The Swatch Book tool provides the possibility to manage colors in so called swatches and 
selectively use them for example for color replacement.  

Before a swatch can be used for color replacement, it needs to be defined in the Swatch 
Books dialog. 

 
Access to Swatch Book Dialog 

Tools > Color & Special Features > Swatch Books. 

 
Add New Colors 

To add new colors, you can choose them by color picker, measure a color on a substratum 
or import from a file. 

 
Print Similar Colors 

The icon Print Similar Colors allows finding the best fitting color for the human eye. The 
created job generates a chart with color variations and their Lab value. 
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Named Colors  
The Named Colors function allows saving colors you need for a special product which can 
be very useful for colors that absolutely have to match every time they are used (for example 
for a logo). 

 
Access to Named Colors 

Tools > Color & Special Features > Named Colors. 

 
Add New Colors 

To add new colors, you can choose them by color picker, add from a swatch book, measure 
a color on a substratum or import from a file. 

 
Print Similar Colors 

The icon Print Similar Colors allows finding the best fitting color for the human eye. The 
created job generates a chart with color variations and their device value. 

 

Measure Colors 
This function can help you to find the Lab values of a color. After a color was measured, the 
dialog Add Color automatically pops up. The Add Color dialog lets you add a name to the 
measured color and adds it to the currently active color tool. 

 
Access to Measure Colors 

Tools > Color & Special Features > Measure Colors. 
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White Ink/Finish/Varnish 
Usually white ink or finish/varnish does not react like color inks. Therefore, you can change 
several factors in the ink settings.  

 
Naming 

You can name the separation color. 

 
Density Linearization 

Since the measurement of white ink or finish/varnish is impossible for many 
spectrophotometers, you can exclude it from the density linearization, use the density 
linearization of the black ink or a default density linearization. 

 
Generate Pixels 

White ink or finish/varnish is often used in separate layers. You can generate pixels on the 
complete image background, only where something is printed or where nothing is printed. It 
is also possible to use an image transparency mask and generate the ink density. To avoid 
or to accentuate the special ink flash at the borders you can reduce or increase the printed 
surface by pixels. 
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Configuration 
Application Defaults 

In the Application Defaults dialog you find all basic settings that can be globally fixed. 

The main settings of the image preset are identical to the global job settings. 

 
Access to Application Defaults 

Tools > Options. 

 
Preferences 

For general presets you can load one in the preferences list or create a new one. The short 
description gives you the main information about the settings. 

 
Image 

 Image format - scale, fit and alignment, rotate and mirror. 
 Print marks - crop marks, register marks, image label. 
 Image AddOns - company logo, seam extension, canvas mounting extension, dashed cut 

line. The following AddOns can be installed: Caption, Label, Eyelets, Gradient Frame, 
Solid Frame, Seam Margin etc. 

 Image margin – predefined margin or personal margins, rotate margins with image. 
 
Color Management 

 Raster Images – select color profiles to be used for images as default input profile – RGB 
images, CMYK images, Grayscale images and Lab images with respective rendering 
intent. 

 PostScript/EPS - use named colors profile for spot color replacement, input profile for 
CMYK data -  chose profile and rendering intent, input profiles for RGB data – choose 
profile and rendering intent. 

 PDF and AI – use named colors profile for spot color replacement, input profile for CMYK 
data -  chose profile and rendering intent, input profiles for RGB data – choose profile and 
rendering intent, input profiles for Grayscale data – choose profile and rendering intent, 
input profiles for Lab data – choose profile and rendering intent. Configure PDF/X 
interpretation. 

 
PostScript/PDF Parameters 

 Automatic raster resolution reduction, minimum resolution. 
 Raster resolution reduced by factor X. 

 
Mask Image 

 Allows selecting files with mask to create very special effects within the job layout. 
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Step and Repeat 

 Configure horizontal and vertical seamless repetition of a pattern. Supported with all file 
types supported by the HP Ergosoft Pro RIP Color Edition. 

 
Job 

 Job default settings - ask for every new job or global settings for media sizeand margins. 
 Extras – outer margin, image center mode, auto tiling and Fotoba marks.  

 
Application 

 Display – monitor profile, units, images, tree view option. 
 Snapshots – store all snapshots in a common local folder, update automatically, image 

folders in use, snapshot display options. 
 PostScript/PDF interpreter – temporary raster files, PostScript RIP, Compression of 

raster data, PostScript buffer size. 
 
Spectrophotometer 

 Type of spectrophotometer. 
 Measurement specification (CIE Illuminant/Observer). 
 Calibration charts – print marks. 

 
User Interface Preferences  

 Selection context menu. 
 Automatic apply discard. 
 Job double click action. 
 Ask to Save Modified Jobs 
 Ask for Infos when creating a new Job 
 Adjust Job to Print Environment 
 Show advanced rendering intents 
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Special features 
 

Step and Repeat 
This command allows importing a pattern to repeat it several times in both horizontal and 
vertical direction. Mirroring and shifting the pattern are also included. The pattern must be 
saved as a TIFF or BMP image. Alpha channels in the image are used as masks so that the 
covered part of the image will be treated as if it would not exist. 

 

Access to Step & Repeat 

Open the Image Import Dialog and from the Filetype Menu, select “Step & Repeat”, or 
Properties > Step & Repeat... 

 

Cutting Job  
This command starts contour cutting of the job on a cutting plotter. It requires that the cutting 
option is included in your software package. You can cut the whole job at once, activate the 
paneling or cut multiple paths per image. 

Note: Please note that cutting the medium after printing is not part of the cutting option but 
enabled in the print environment and the printing dialog when the used printer supports this 
function. 

 
Access to Cutting Option 

 (cut environment),  (cut settings),  (contour cutting activation) icons in the toolbar, or 
Tools > Cut Environments… 
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Linearization and Profile Tools 
Even before we print out an image, we have a distinct idea of what the image should look like 
in print. To achieve this goal, we need to be able to tell the printer exactly how the image is 
supposed to look using RIP software. Before we can make these guidelines, we have to 
analyze how the printer reacts without external influence. Therefore, you need to do a 
density linearization to know the behavior of your printer. After that, limit the ink amount and 
finally create an ICC profile. For more detailed information, please refer to the concerning 
application note. 

 
Density Linearization 

Inkjet printers often have a problem caused by mechanical limitations: the optical impression 
of the printout is not linear from 0% to 100%. 

The density linearization has to compensate the non-linear behavior of the printer. This can 
only be done when the characteristic of the printer is exactly known. To get this information, 
the density linearization process is printing and measuring customized calibration charts. 

 
Creating New Density Linearization 

Tools > Linearization & Profile Tools > Density Linearization. 

Note: To assure a stable density linearization, the curve must be limited. 

 
Density Relinearization 
The density linearization should be repeated from time to time to make sure that the printer is 
still in a linearizised state. The density relinearization offers the density linearization with fix 
settings extracted from the current density linearization so that the conditions for the 
relinearization cannot be changed. 

 

Realizing a Density Relinearization 

Tools > Linearization & Profile Tools > Density Relinearization. 
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ColorGPS 
ColorGPS creates a color profile conform to the ICC standards, which characterizes the 
maximum color space of the printer. The technical term for a printer’s color space is gamut. 

By using an output profile created with ColorGPS you can make sure that all input files, 
regardless of input color space are rendered color-accurately. 

ColorGPS is an IN-RIP solution, which can only be used as part of an Ergosoft RIP. Such an 
IN-RIP solution has the advantage that the profiler has a direct access to data such as e.g. 
the density linearization. Furthermore, data such as the calibration grid do not need to be 
exported and imported, but can be processed directly within the program. 

To create an output profile for a printer, the print environment must already contain a density 
linearization. The density linearization is the basis for the output profile. ColorGPS even 
offers the possibility to create output profiles using only the density linearization. 

 
Access to Color GPS  

Tools > Linearization & Profile Tools > ColorGPS. 

 
Color Boost  

The Color Boost option allows you to intensify colors. After the measurement of the ICC 
profile you can increase the color intensity to get an over-saturated profile. Recalculate the 
profile after changing the intensity – Options > ICC Color Intensity. 

 
Test Images   
The Ergosoft RIP comes with some test images, for example an ink limit chart for 
determining the maximum amount of ink that the media can absorb and a CMYK chart. Use 
these images to get the best printing result - Tools > Linearization & Profile Tools > Test 
Images or Right Click > Test Images 
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Other Tools 
 
Variable Data  
Some jobs require printing the same design (image, background, object, etc.) with 
personalized text or (consecutive) numbering. Instead of creating a separate image for each 
combination it is possible to use the Variable Data option to create a template with just the 
fix part of the object and let the variable text or numbers be automatically added when the 
template is used. For an in depth explanation of the Variable Data option, please see the 
Application Note: “Variable Data”. 

 
Creating a Variable Data Template 

Tools > Variable Data Template > New. 

 
Using a Variable Data Template 

right click > Add Variable Data Images or Tools > Variable Data Template > Add Variable 
Data Images. 

 
Picture Package  
Often, photographers offer sets of portraits with the same photo in different sizes printed on 
one big sheet. The picture package does exactly the same; it allows importing the image just 
once and positions it automatically in the picture package template to create a custom set of 
this image. 

 
Creating a Picture Package Template 

Tools > Picture Package Template > New. 

 
Using a Picture Package Template 

right click > Picture Package or Tools > Picture Package Template > Add Picture Package. 

 
Position Template  
This function allows you to preset positions for various images. This is very useful if you need 
to print on a certain place on your medium (for example for T-shirt printing). 

 
Creating a Position Template 

Tools > Position Template > New. 

 
Using a Position Template 

right click > Position Template or Tools > Position Template > Select Position Template. 

Separation Printing  
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To print film positives, the separation job function automatically separates your image file into 
individual images for each color channel. – File > New Separation Job. 

 
 
Hot Folder  
In order to make batch printing of images easier, the Ergosoft RIP offers the optional Hot 
Folder function. 

The usage of hot folders makes printing standardized jobs a piece of cake. You just have to 
create a folder with the images to be printed, that is linked to the appropriate Hot Folder. 
The Hot Folder is linked to a print environment as well as to some production specific 
settings. 

When the Hot Folder is active, storing an image in the folder that is linked to it will 
automatically start the print job and process it without the need of any user interaction. 

The program parts JobComposer and Rip Server do their jobs as background tasks and do 
not need to be started manually.  

All production modules such as JobCenter and Print Client are still available and can be 
used as usual. 

The Hot Folder setup is divided in the following tabs: 

 
General Tab 

Specify the folder of the images to be printed, put the Hot Folder off- or online, choose the 
method of processing the files after printing, choose print environment. 

 
Job Tab 

Define media size, use position template, define job length before starting printing, use 
Fotoba print marks, suspend RIP, suspend printing, keep Rip data after printing, generate job 
preview. Choose between different nesting modes are within the HotFolder application. 
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Image Import Tab 

Number of copies per image, image preset, description of image preset, picture package. 

 
Contour Cut Tab 

Activate contour cutting, choose cut environment, path settings, passes. 

 
Preflight 
The preflight function should principally help you to avoid printing error rates for important 
productions. You have the possibility to have a preview on your monitor or on another 
medium printed on a smaller printer used as proof. 

 
Manual Preflight 

Job Properties window > Job Production > Job Preflight.  

 
Automatic Preflight 

 Tools > Options > Preferences > Job > Job Default settings > Processing Policy > Preflight. 

 
Soft Proofing 

Soft proofing means that the preview is visible on your screen. You can generate a RGB 
Jpeg or a RGB Tiff preview. For printers with more colors choose the Device Tiff. Choose a 
profile and a resolution. For Device Tiff you can also decide to raster PostScript/PDF for 
target printer resolution. 

 
Print Proofing 

Print proofing means that you print your image on a proofing printer simulating the target 
printer. The preflight mode Print allows you this simulation. Choose a print environment of 
your target printer and the width and height of the printout. 

To proof another printer, you can set the profile for target printer simulation in the Extras tab 
in the print environment. 
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RGB Profiling and Printing 
The Ergosoft RIP offers for some printer drivers the possibility of RGB output with help of 
Windows printer drivers with very limited output calibration possibilities: Just the RGB printer 
profile can be used; density linearization and ink limitation are not available. Color 
replacement is available in a very limited way. 

To create a RGB profile, choose a RGB driver and create a new print environment. 

Note: It is very important to select the right media! The ink amount is pre-limited for each 
media. 

 
Calibrating for RGB Output 

The calibration for RGB output consists only of printer profile creation in ColorGPS. You 
simply need to print the calibration chart, measure it and calculate the profile. All other 
components are set by the printer. 

 
User Level 
User Level Rights allow to protect certain elements with a password to increase production 
security. In Version 15 the User Level Rights bring adjustable user levels, including 
JobQueue features and adding supplementary JobComposer functionality to the control. 

Manage User Levels 

Windows Start > Maintenance Tool > Manage User Levels 

 

Change User Level in JobComposer 

Toosl > User Level 

 

Scan and Twain Source 
Import an image from an external device. 

Access to Scan and Twain Source 

File > Scan, select an external device for importing images – File > Twain Source. 
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Maintenance Tool  
Configuration 
Some basic configurations concerning the RIP software itself can be set here. 

 
Select User Interface language 

You can choose one of the supported languages for the user interface. 

 
Set User data path  

You can change the folder in which the user data such as print environments and 
configurations are saved to switch from basic installation to another one. 

 
Automatically Start Program 

If you activate the Startup Manager you can run several RIP Servers at the same time (what 
helps you enormously to reduce waiting time) as well as choosing the threads per server. 
You can activate the checkbox to start the JobComposer at Windows start and initiate 
various Print Clients from the beginning. 

 
Activate Windows Explorer Job Previews 

Activates the thumbnail preview for jobs inside the Windows Explorer 

 
Deactivate Windows Explorer Job Previews 

Deactivates the thumbnail preview for jobs inside the Windows Explorer 

 
Manage User Levels 

Let’s you create and manage specific User Levels with different rights 

 
Show License Info 

Opens your Web browser and shows information about your License 

 
  



Reference Manual – HP Ergosoft Pro RIP Color Edition  48 

Troubleshooting 
Some problems that may occur can be solved with the following functions. 

 
Create Support Data ZIP File 

Create a data file with information needed for support purposes that you can send to your 
support partner on request. 

 
Register COM Interfaces 

Run if you come upon an installation or registration problem. 

 
Empty Snapshot Folder List 

Clear the list of monitored image folders. 

 
Delete all temporary raster files 

Clear the list of monitored image folders. 

 
Reset Current Print Environment 

Run if you have a problem with a specific print environment (e.g. after a system crash). 

 
Reset Current Cut Environment 

Run if you have a problem with a specific cut environment (e.g. after a system crash). 

 
Shut down all RIP components 

Run only if program is blocked. Be careful! Not saved files might be deleted! 

 
Reset current JobComposer workspace 

Resets the current JobComposer to its default settings (Not saved files might be deleted!) 

 
  



Reference Manual – HP Ergosoft Pro RIP Color Edition  49 

Documentation 
About 
This dialog gives some information about your version of the HP Ergosoft Pro RIP Color 
Edition: Version information, and folder in which the user data are saved. 
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HP Color Tool Guides 
HP Easy Profiling 
HP Easy Profiling is a powerful profiling wizard. Taking advantage of Ergosoft’s advanced color 
profiling algorythms and HP’s industry leading printer technology to deliver an easy to use 
workflow to create color profiles for your specific material and get the most out of your HP 
Printer. 

Requirements: HP Ergosoft RIP Color Edition, HP Stitch Printer, Spectrophotometer (X-Rite 
i1, X-Rite i1 iO and Barbieri Spectro LFP are supported). 

 

Step 1: Creating a new Substrate on the Printer 

 

To create a new substrate, access the printer’s 
touchscreen panel and navigate to the 
Substrate library.  

 

From the available selection of general 
substrate types (Transfer Paper, Transfer Film 
and Direct Fabric), select the one that 
corresponds to the overall material type you 
want to use and then select the first option + 
New ... . For this example we’ll use + New 
Direct Fabric.  

 

 

 

Next, a popup will appear that allows you 
to make a finer selection of substrate 
type. Select a generic substrate type that 
best matches yours.  

 

After selecting the substrate type, a quick 
guide window will appear, giving an 
overview over the two step substrate 
creation process on the panel and in the 
RIP.  

 

Click Continue to proceed. 
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The following dialog lets you specify the 
appropriate settings for the new substrate. 

 

Adjustable parameters are Passes, Heater 
Temperature, Color Saturation, and Name for 
the substrate. More in depth settings are 
available by clicking the Advanced Settings 
button.  

 

After making the desired adjustments, click 
Print test to print out a test chart to check if the 
settings are suitable for your substrate. When 
you are ready to proceed, click Continue. 

 

 

 

 

A confirmation window will appear, 
instructing you to complete the substrate 
creation process by making an ICC 
profile in the RIP.  

 

Click Finish to confirm and return to the 
substrate library, where whe new 
substrate should now be selected.  

 

 

 

Next, move to the PC to begin the ICC profiling procedure. 
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Step 2: Connecting the RIP to the Printer 

To begin the profiling process, take the test chart we printed during the substrate creation and 
keep it close by.  

 

Open the HP Ergosoft RIP Color Edition and 
access the HP Color Tools bar.  

 

Select HP Easy Profiling to start the profiling 
process. 

 

In the first dialog, select your printer model, e.g. 
HP Stitch. Then click Next to proceed. The HP 
Easy Profiling Wizard will then attempt to 
establish a connection to the printer and wake 
it from standby mode if required. 

 

 

 

Step 3: Select Media and Print Mode 

 

 

Once the connection is established, the 
printer will retrieve the material and print 
mode lists from the printer.  

 

In Select the Media, choose the material 
from the printer that you would like to 
create the profile for.  

 

In Select the Print Mode, select the print 
mode that the profile should be created 
with. 

 

If the material and/or printmode that you would like to use is not selectable in the dropdown 
menus, please verify that they are properly set up on the printers panel, then go back to the 
first dialog and then click Next again so the material and printmode list is retrieved again. 

Once you have selected the appropriate material and printmode, click Next to move on. 
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Step 4: Profile Name 

This window lets you specify a name for the Print Environment that will be created.  

 

This is the name under which your set of 
parameters will appear in the RIP when the 
profiling process is completed, so we 
recommend using a unique, descriptive name 
for the Print Environment. 

 

When you have entered the name, click Next 
again to continue.  
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Step 5: Measuring 

At this point we will be measuring the chart you printed out beforehand and then letting the HP 
Easy Profiling Wizard calculate the color profile for you based on the measurements. 

To start, take the color chart you printed from the printer’s panel beforehand, connect your 
measurement device to the computer and click the Measure Button.  

This brings up the measurement dialog that allows you to conduct and manage measurements. 

 

 

The measurement dialog consists of 
three main areas: 

 

Chart Ids: On the left top side you’ll find 
the segment that lists the ID and number 
of charts that are expected. 

 

Expected and Effective Measurement 
Results: In the center, you’ll find a visual 
representation of the expected color in 
the chart. When measuring, the actual 
measured colors are also displayed here.  

 

DeltaE: The segment on the right hand 
side displays the color difference 
between expected and measured color 
for the selected patch. 

 

To begin the measurement process, first click on Spectrophotometer, select your Device from 
the dropdown menu, then click Detect and wait for the connection to be established. 
After the device is detected, confirm with Ok. 

Next, click Measure to start with the actual measurement.  
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Measure each color patch on the chart with 
your device in single measurement mode 
(Scan modes are not supported) until the entire 
chart is measured.  

 

Visually check if the measured values are 
approximately match up with the expected 
values to make sure there were no 
measurement errors. If any colors are vastly 
different, simply replace the measurement by 
selecting the patch and re-measuring. 

 

 

When you are satisfied with the measurement, click Ok to save the measurement, this will take 
you back to the Step 4 Dialog.  

 

Step 6: Generating the Profile 

 

 

You’ll find that the HP Easy Profiling Wizard has now created a new Print Environment in your 
HP Ergosoft RIP Color Edition that is automatically set to the print parameters you selected, 
has the proper port configured and your new profile embedded, ready for you to start your 
optimized print production! 

 

  

 

  

 

Click Create to create the profile. This will 
use the measured values and calculate 
an accurate color profile for your 
printer/media combination. Once the 
calculation is complete, click Finish to 
complete the process.  
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Print Pantone Emulation Swatchbook 
 

HP Ergosoft RIP Color Edition allows users to easily print color samples of their Pantone Swatchbooks 
to check color accuracy of the profile on a given medium, ensuring that all colors appear exactly as they 
should.  

To access the Print Pantone Emulation Swatchbook feature, it is important to select a Print Environment 
with an embedded Profile. If you do not have one already, you can easily set one up either by using the 
HP Easy Profiling tool or import one from HP’s extensive library through the HP Stitch Colorbase. 

 

Accessing the Feature 

 

 

 

Once a Print Environment with profile is in place and 
selected, access the HP Tools Bar and select Print 
PANTONE Emulation Swatchbook. 

 

 

The opening dialog allows you to configure which Pantone colorbook should be printed and the 
arrangement of the color strips. 

 

Selecting the Swatchbook 
From the Dropdown-Menu, select the appropriate Swatchbook that best matches your application. 
  
 
Pantone Solid Coated: Color Library of 
reference color patches suitable for coated 
(Glossy) materials. 

 

Pantone Solid Uncoated: Color Library of 
reference color patches suitable for uncoated 
(Matte) materials. 

 

Pantone Pastels & Neons Coated: Color Library 
of pastel and neon color patches suitable for 
uncoated (Matte) materials. 

 

Pantone Metallics Coated: Color Library of 
metallic color patches suitable for uncoated 
(Matte) materials. 
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By checking the Print Color strips vertically box below the colorbook selection, the individual color 
patches are rearranged to vertical direction. 

 

Generating and Printing the Swatchbook Job 

When satisfied with the settings, click Create Swatchbook Job. The Ergosoft RIP will then calculate the 
color values of each Swatchbook color through the profile and create a job with color adjusted charts. 

Once the chart has been created, exit the Print PANTONE Emulation Swatchbook tool using the Exit 
button.  

 

 

Before printing, you have the opportunity to edit 
the print job to suit your application using 
Ergosoft RIP’s selection of job editing tools 
such as rotating, mirroring, positioning, 
cropping, etc.  

 

 

Once you are ready to print, click the Print 
button in the Toolbar and confirm the Print 
dialog with Ok to send your Pantone Emulation 
Swatchbook job to the printer. 
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HP Professional Pantone Emulation 
HP Professional Pantone Emulation analyzes image files for Pantone spot colors and 
compares these spot colors to the printable color space of your color profile. By comparing the 
recipe of the spot color with the possible output, HP Professional Pantone Emulation will 
display warnings for colors that cannot be accurately printed with the current profile and then 
allow you to not only find a suitable replacement color but also to substitute them for printing, 
all within the same tool. 

To use HP Professional Pantone Emulation, first make sure that your Print Environment 
contains a color profile that the Pantone values can be compared to. Then, import an image 
file that contains spot colors into the Ergosoft RIP HP Color Edition.  

 

Accessing the Feature 

 

 

Next, start the HP Professional Pantone Emulation 
tool through the HP Tools -toolbar. Note that if HP 
Professional Pantone Emulation is not selectable 
from the toolbar, i.e. grayed out, your image files 
likely does not contain any detectable spot colors.  

 

 

 
The Color List 

After starting the HP Professional Pantone Emulation tool, the color list dialog will appear. By 
default, the segment on right of the window will show a list of spot colors in the file that are out 
of gamut, i.e. not printable exactly with the current profile (By checking the Show all colors 
checkbox, the list will not only display out of gamut colors, but all spot colors detected in the 
file). 

If the list is empty, all the detected spot colors are printable, congratulations! 

 

If there are out of gamut colors in the list, HP 
Professional Pantone Emulation lets you 
adjust the colors to printable color recipes.  

 

To do this, simply double-click on the color 
you would like to adjust. 
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Color Details 

Double-clicking a color in the color list takes you to the adjustment dialog. This window displays 
several useful data points of information, such as the original pantone color both in name and 
an actual representation of the color, as well the suggested replacement color and the 
difference between the original color and the replacement color in deltaE. 
 

 

The adjustment dialog will show the 
automatically suggested replacement 
color that most closely matches the original 
pantone color. The replacement color is 
shown both as a visual representation next 
to the original color as well as in CMYK 
values. 

  

This is the color that will automatically be 
used when printing the file as is.  

 

 

 

 

If you are satisfied with this color, there is nothing else you need to do. Simply click Back and 
verify the next color in the list.  

If you would like to customize the replacement color, click on Advanced Settings to select a 
different replacement color. 
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Advanced Settings (Further Color Adjustment) 

In Advanced Settings, you can set a custom replacement color for the original, out of gamut 
Pantone color, by simply selecting a color you like from a grid of similar colors. You can even 
adjust the color grid to get you closer to the desired color: 

 

Step Distance: Sets how far apart the 
individual patches from the grid are. 
Increasing the step value means larger 
differences between the shown colors so 
larger shifts are possible. 

 

CMYK: Shows the CMYK value of the 
currently selected color. You can also enter 
custom color values here if you already know 
the replacement value.  

 

Print Color Variations: This button will 
create a job of the current grid and send it to 
the printer. This allows you to quickly print the 
color swatches in the grid to judge which one 
best matches your expected results.  

 

 

Apply these color changes to the permanent color table of named colors: By default, an 
adjustment for a color defined through HP Professional Pantone Emulation is only applied to 
the currently selected image. By checking this box, the adjustment/replacement of the color is 
saved in the Print Environment as a Named Color Profile, so the adjustment/replacement is 
made every time a color with the same name is printed. 

 

Saving your Changes 

Once you have found and selected your desired color that closely represents your pantone 
color, click Save to select the color, and Save again in the following dialog to apply the 
replacement.  

This will take you back to the original list, from where you can move on through the out of 
gamut colors to specify suitable print values for each of them.  

 

 

Note that once a spot color has been assigned a 
replacement value, it will show a small pencil 
icon next to its list entry, allowing you to easily 
keep track of which colors have been 
adjusted/replaced. 
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